Starting with 7:00 a. m. we are facing a partial degradation of the payment page. Some customers might encounter some errors. Thank you for your understanding!
Incident Report for PayU Romania
Resolved
This incident has been resolved.
Posted Nov 14, 2024 - 07:51 UTC
Update
We are continuing to investigate this issue.
Posted Nov 14, 2024 - 07:33 UTC
Investigating
We are currently investigating this issue.
Posted Nov 14, 2024 - 07:33 UTC
This incident affected: Authorization (Card Payment).